Truehost Cloud Status

Some systems are experiencing issues.

2 months ago —
Fixed

Fixed

2 months ago —

All Services Restored

The recent server outage has been resolved. All affected services are now back online and operating normally.

We apologize for the disruption and thank you for your patience.

Identified

2 months ago —

An issue affecting server LON105 is still ongoing. Following the maintenance, we identified a problem with some components responsible for connecting the server to its storage.

Our team is actively working on resolving the storage issue and restoring the service as quickly as possible. We will continue to provide updates as progress is made.

2 months ago —

Hello,

We are aware of an issue with LON105 cPanel server. The server has had issues connecting to its storage after a maintainance operation.

Affected services: Websites,Emails, Expected downtime: 2hr

Affected servers: cPanel server: LON105

Our team is actively working on this and an update will be provided shortly.

Incident UUID d420823e-924e-42bf-b55f-026fa24c7f87