Some systems are experiencing issues.
Update
cPanel and Webmail accessibility has been enabled for all users. You can use the normal links to access cPanel or Webmail. eg, if your domain is truehost.com, use the following links:
cPanel: truehost.com/cpanel or cpanel.truehost.com Webmail: truehost.com/webmail or webmail.truehost.com
Reseller WHM access is still not yet activated. We are completing checks and verification on this before activation.
Update on Accessibility
We have been monitoring the situation around CVE-2026-41940 as cPanel continued to provide updates.
After checking, we are more confident the vulnerability has been addressed from our forensic checks.
We are now initiating the process to restore access to cPanel, Webmail and WHM access for resellers. ETA is 1hrs from now.
Emergency Port Block – CVE-2026-41940 (Critical cPanel Vulnerability)
As part of our ongoing response to the critical security vulnerability CVE-2026-41940 affecting cPanel & WHM, we have taken the precautionary step of blocking the following ports across all of our shared hosting servers:
• Port 2083 — cPanel Web Access (HTTPS)
• Port 2082 — cPanel Web Access (HTTP)
• Port 2087 — WHM Access for Resellers (HTTPS)
• Port 2086 — WHM Access for Resellers (HTTP)
• Port 2095 — cPanel Webmail (HTTPS)
• Port 2096 — cPanel Webmail (HTTP)
• Port 1624 — cPanel SSH Access
These ports will remain blocked until we are confident that all servers have been fully patched and verified as secure.
Why We Did This
CVE-2026-41940 is a critical zero-day vulnerability in cPanel & WHM, rated 9.8 out of 10.0 in severity. It allows unauthenticated attackers to completely bypass login authentication and gain full administrative access to hosting servers, putting websites, databases, email accounts, and files at risk.
This vulnerability has been actively exploited in the wild. Blocking these ports immediately is the recommended mitigation measure issued by cPanel themselves while patches are verified across our infrastructure. The security of your data is our top priority.
Affected Services
The following services are temporarily unavailable as a result of this action:
• cPanel control panel (web access)
• cPanel Webmail
• WHM access for resellers
• SSH access via cPanel (port 1624)
All websites, domains, and email delivery continue to function normally. Only administrative access interfaces are affected.
Accessing Your Email in the Meantime
If you use cPanel Webmail to read your email, you will not be able to access it via the web interface while this block is in place. We recommend configuring your email account in a desktop or mobile client such as Microsoft Outlook using the standard IMAP/POP3 and SMTP settings for your domain.
If you need help setting up Outlook or another email client, please contact our support team at support@truehost.cloud and we will assist you.
What We Are Doing?
Our team is working urgently to:
We will update this notice as soon as ports are cleared to reopen and will notify all clients directly once normal access is restored.
Questions or Urgent Support?
If you have any concerns or require assistance during this period, please reach out to our support team. We are prioritising tickets from affected clients.
Thank you for your understanding as we take these necessary steps to protect your hosting environment.
— The Truehost Infrastructure Team
Incident UUID c8fe425e-546d-4723-993e-f316c23c0e6f