Truehost Cloud Status

Some systems are experiencing issues.

Plesk Windows Hosting

Fixed

2 months ago —

Dear Clients,

We apologize for the delay in providing updates. During the restoration process, we encountered minor issues that required extra attention. All active accounts on the affected server have now been successfully restored.

At this stage, our team is conducting a thorough review of the restorations and overall server performance to ensure account ownership, permissions, and configurations are correctly applied. This review is necessary to confirm that all impacted accounts are fully accounted for and functioning as expected.

We sincerely apologize for the delayed communication and appreciate your patience during this process. Should you experience any issues or require clarification, please do not hesitate to contact our support channels.

Thank you for your understanding.

Fixed

2 months ago —

Restoration still in progress.

Fixed

2 months ago —

Full Server Restoration Now in Progress

Following our previous update about the database recovery on lim301.truehost.cloud, we need to inform you that the initial restoration approach was not successful. Additionally, we discovered that most MSSQL databases have also crashed, requiring a more comprehensive recovery solution. Updated Recovery Plan: We have now initiated a full server restoration to recover the complete state of all services and data. This approach will ensure we restore everything from a known good state rather than attempting piecemeal database recovery. Revised Timeline:

Full Server Restoration Started: January 29, 2026 - 10.00 EAT Expected Completion: 24-48 hours from start time Next Update: 6:00 PM EAT today

Services Affected: All services on lim301.truehost.cloud will be temporarily unavailable during the restoration process, including:

MySQL/MariaDB database services MSSQL database services Web applications and dynamic website content Plesk control panel functions Email services FTP/SFTP access All website content

Our Sincere Apologies: We understand this incident has taken much longer than initially expected, and we deeply apologize for the extended disruption to your services. Our team is working around the clock to complete this full restoration and return all services to normal operation. Data Safety: All customer data will be restored from our comprehensive backup system. We are committed to complete data recovery. Support: For urgent concerns, contact: support@truehost.cloud Status Page: https://status.truehost.com

Fixed

2 months ago —

We've identified that certain MSSQL databases are not appearing in client panels due to subscription configuration issues. We are currently working to restore the missing configurations and properly align them with their respective subscriptions. Our sincere apologies for the inconvenience.

2 months ago —

Emergency Database Recovery in Progress

We experienced an unexpected database crash on server lim301.truehost.cloud and are currently performing full database restoration to recover all data and services.

What Happened: Our server experienced a critical MySQL/MariaDB database failure that resulted in data corruption. We initiated emergency recovery procedures using our latest backups to restore all customer databases.

Timeline:

  • Incident Detected: January 28, 2026 - 11:30 AM EAT
  • Recovery Started: January 28, 2026 - 12:00 PM EAT
  • Expected Completion: January 28, 2026 - 9:00 PM EAT
  • Duration: Approximately 8 hours

Services Affected:

  • MySQL/MariaDB database services (DOWN)
  • Mysql Database-dependent web applications (IMPACTED)
  • Plesk control panel database functions (IMPACTED)
  • Dynamic website content requiring database access (IMPACTED)

Services Operational:

  • Mssql database services - OPERATIONAL
  • Website files remain accessible
  • Email services (sending/receiving) - OPERATIONAL
  • FTP/SFTP file access - OPERATIONAL
  • Static website content (HTML/CSS/JS files) - OPERATIONAL

Data Safety: All customer data is being restored from our automated backup system. We expect full data recovery with minimal data loss.

Updates: We will post regular updates here as the restoration progresses. Our technical team is actively monitoring the recovery process.

Support: For urgent concerns, contact: support@truehost.cloud

Status Page: https://status.truehost.com

Incident UUID 2ae7b64c-fa0a-4033-b09a-13298d015288